Jump to content
  • 0
XTwistedD

Failed to establish connection with the server instance

Question

so i got the files and setup to make my own dedicated server and for what i can see i did everything like it should, whenever i start the server using line:start "" "D:\yds\Ylands\YlandsDs.exe" -logfile "%CD%\log.txt" -nographics -batchmode
i get this error in the monitor screen: Failed to establish connection with the server instance

So i know it creates the log files and thats where i could see what things go wrong so i upload those with this topic. does any of you had this before? and can you see what i did wrong?

log.txt

log_clean.txt

Edited by XTwistedD

Share this post


Link to post
Share on other sites

5 replies to this bug / suggestion

Recommended Posts

  • 0

Well for some reason i can't look at those files, would be a great help if i could.

If you setup the Config file and ini file correctly, it should work.

Otherwise if its flat out refusing connection, then possibly a firewall issue.

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Energritz_ said:

Well for some reason i can't look at those files, would be a great help if i could.

If you setup the Config file and ini file correctly, it should work.

Otherwise if its flat out refusing connection, then possibly a firewall issue.

Hmm strange i can open them on my mobile🤔 later this day i will put them in a reply. 

Anyhow as far as i can see i did the right thing. I will upload my DsConfig.json and Ylands.ini file also later so that maybe someone sees whats wrong

Share this post


Link to post
Share on other sites
  • 0
Initialize engine version: 5.6.3p2 (b3d7a6428558)
Forcing GfxDevice: Null
NullGfxDevice:
    Version:  NULL 1.0 [1.0]
    Renderer: Null Device
    Vendor:   Unity Technologies
Begin MonoManager ReloadAssembly
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\UnityEngine.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-UnityScript.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\UnityEngine.UI.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\UnityEngine.UI.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\UnityEngine.Networking.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\UnityEngine.Networking.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\LitJson.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\LitJson.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\System.Drawing.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\System.Drawing.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\System.Windows.Forms.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\System.Windows.Forms.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\udpkit_wp8.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\udpkit_wp8.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Unity.IO.Compression.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\Unity.IO.Compression.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Mono.Nat.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\Mono.Nat.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\HeadlessServerMonitorShared.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\HeadlessServerMonitorShared.dll into Unity Child Domain
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\TextMeshPro-1.0.55.56.0b11.dll (this message is harmless)
Loading D:\yds\Ylands\YlandsDs_Data\Managed\TextMeshPro-1.0.55.56.0b11.dll into Unity Child Domain
- Completed reload, in  2.171 seconds
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\System.Core.dll (this message is harmless)
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\System.dll (this message is harmless)
WARNING: Shader Unsupported: 'Ylands/Terrain' - All passes removed
UnloadTime: 0.909821 ms
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Mono.Security.dll (this message is harmless)
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\System.Configuration.dll (this message is harmless)
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\System.Xml.dll (this message is harmless)
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Accessibility.dll (this message is harmless)
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Mono.WebBrowser.dll (this message is harmless)
Platform assembly: D:\yds\Ylands\YlandsDs_Data\Managed\Mono.Posix.dll (this message is harmless)
Unloading 5 Unused Serialized files (Serialized files now loaded: 0)
Unloading 6002 unused Assets to reduce memory usage. Loaded Objects now: 3712.
Total: 15.024667 ms (FindLiveObjects: 0.445595 ms CreateObjectMapping: 0.725633 ms MarkObjects: 12.778058 ms  DeleteObjects: 1.074478 ms)
Setting up 2 worker threads for Enlighten.
  Thread -> id: 224 -> priority: 1
  Thread -> id: 3440 -> priority: 1

Share this post


Link to post
Share on other sites
  • 0

i got it to work. apparantley i missplaced a coma or something somewhere. also i had 3 ylandsDS.exe running in my TaskManager i got a lot of help from the P1 guys. his name in this forum is RedEagle, give him some love <3

Edited by XTwistedD

Share this post


Link to post
Share on other sites
  • 0

Is it possible for you to move this topic to the Dedicated Server Beta Feedback subforum, please? Not to confuse other players (I can't move it myself)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×