Jump to content
Sign in to follow this  
anna_svecova

Dev Diary #235 Patchworking Problems

Recommended Posts

Hey there, Ylanders,

first of all we want to thank you for all the feedback we got on Update 1.10: Ymproved Ylands. We love to see that so many of you enjoy the update. You may be wondering why there are two patches and why their release is planned so close to each other. This is important to mention, as it is all thanks to you (that is a good thing!). You reported issues and we got to fixing them right away, got a patch ready so that the most pressing issues, some of which happen to be fairly easy to fix, can be fixed as soon as possible. While we deal with everything that needs to happen for us to be able to release the patch (remember this Dev Diary? ) we continue working on fixing what needs fixing and start preparing the second patch.

While our QA caught many issues that have already been fixed before the update, you, our wonderful players, have helped us catch a few more pesky bugs and we are very grateful for that. The team is already hard at work and almost all of the reported problems are already fixed on our internal version of the game and will be coming to you in two patches very, very soon. 

First Patch

As you may have noticed, there are some issues regarding ships. In the first patch, we are going to fix the "disappearing act" of some blocks, which certain players experienced, when disassembling their ship. This patch should be going live at the beginning of next week.

Second Patch 

Patch number 2 will focus on issues related to Blueprints, in which we aim to fix two main issues. The first being that some of the Blueprints were not fully built after depositing all the necessary resources required by the Blueprint. The second being related to dropping tools in the middle of the building process. 

All of these issues are connected and overlap. We are working on fixing all the issues reported by you, so please, continue giving us your feedback, continue reporting anything that doesn't seem right and we will keep in touch! 

Thank you for your contribution, help and patience.
We love our community.

Stay classy!

DD235_fin.png

  • Like 6
  • Upvote 1

Share this post


Link to post
Share on other sites

Hello,

Unfortunately, I've had a similar problem a few times... see here:

https://ylands.com/community/topic/31830-problem-with-building-a-ship-from-blueprint/

Over time, I found that of the decorative items I used, only the plain rope would occasionally go bad. And in addition to rope, I also use planks, wooden stakes, steel rods, bark, feathers and some tools as decoration. (I don't use traditional 1x4 logs, iron bricks, nails and fabric though).

The problem manifests itself in that sometimes when you put rope in decorations, you can't deliver it between on building materials and vice versa. The simple advice is to put everything between the main building materials. Without it, you can't complete the blueprint and you run the risk of losing the unbuilt ship completely (it happened to me twice, once in exploration and then in creative mod). If you don't add it between the decorations, then after the build is interrupted, you'll find the ship finished without just a few decorative ropes.

But I have one question. I don't know if it's a bug or intentional, but if you make a blueprint from the editor, all decorative items are not built as collectible even if they had interaction turned off in the editor. It's just a small detail, but if you make a ship then you waste a lot of time curing all the decorative items. The problem is that some items are hard to get to, and other times it's quite tedious. (I have over 350 iron bars and 80 breads on my ship that make up my rigging.)

Likewise, when you put a regular blueprint for the game into the editor, all the parts and blocks are collectible when you test, including the basic building blocks. I haven't figured out how to turn this off yet. Do you know how to prevent this?

Overall though, the 1.10 update is a big step forward. I especially like the new workstations and especially the export from the editor. Since I couldn't export blueprints from the editor it was just a marginal addition for me. I spent almost all my time in the game exploring. Until the 1.10 update was announced, but now I'm spending more and more time in the editor, trying to make both new ships and buildings. Overall, it's a huge qualitative leap forward not only for the editor, but also for exploration, and I thank you for it from the bottom of my heart.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

ahoj. uz som si pisal s vyvpjarmi a moznost zbierat entiy s planu bude upravena. zial asi az v dalsom update. v editore si to ale môžete zmeniť buď v nastaveniach mapy, "položené entity zobratelne",alebo v nastaveniach entit,zobratelne. a tiez uz sme davali niekolko navrhov na novy nanstroj alebo system vytvrdzovania,tak snad nam nieco vytvoria. 

Hi. I have already written to the developers and the possibility to collect entities from the plan will be modified. probably in the next update. in the editor, however, you can change it either in the map settings, placed entities removable, or in the entities settings, removable. and we have also already given several proposals for a new device or system for hardening, so maybe they will create something for us.

Edited by Mello1223

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×