Jump to content
  • 0


(See post nr 3.)


I am having quite serious graphical issues.

OS: Win7 Ultimate(BLANK!!! nearly no windows updates, no genuine yet.)
PC: i7 3770, 8GB ram
Graphics: AMD RADEON HD 7800 (2GB)
game version: (latest?) 0.22.30657

List of graphic bugs in menus:
1) No background in main menu [PICTURE 1]
2) No background in character creator.
3) Gameplay mode selection thumbnails (only left column?!) are black sometimes. [PICTURE 2]
(savegames display as ingame screenshot)
4) No game loading background. [PICTURE 3]
5) Occasionally when exiting game (by endtask/ALT+f4) screen filps upside-down.

List of ingame bugs:
1) Most of the time all but HUD is black. (game seems to work; I can walk, interact, have been killed etc.) [PICTURE 7]
2) Other times screen is purple. (found a way removing purple screen by disabling HBAO+, replaces with black/poly) [PICTURE 8]
3) Sometimes one single degree shows a flash of beige (mostly) background.

4) At occasions (1 out of 10 created worlds) i have reached actual polygonal content. (mostly trees) Oddly restricted by ~90 degree angle.(red lines show how far cursor could travel before blacking out.) [PICTURE 4]
5) Most cases objects draw multiple times on screen [PICTURE 5]
6) Menu sometimes displays as seen on picture 6, sometimes doesn't appear at all.
7) Polygonal content is either missing, too bright or black.

Games ability to render anything (menu, poly-content, HUD) seems to be decreasing with time/actions.

List of tests, fixes I've tried.
1) Newest version of gpu driver
2) Changing resolution does nothing but fixes menu buttons.
3) Changing any quality settings doesn't affect anything.
4) Neither does windowed mode.
5) First test with minimal graphics in a creative world added some progress on toolbar[PICTURE 9]
6) Reinstalling game didn't help.

As far as i can tell, game is running smooth on background, sometimes I can see objects annotations and can interact with them. [PICTURE 10].
I myself am suspecting that I might have some crucial files for Unity engine missing, though haven't tried any other Unity games with this new PC setup.
Also environmental lightning seems to play a role as if when object is too dark, it is rendered black.
Looking forward to be able to play.

More recently I haven't been able to render any polygonal content.










PICTURE 4: (out of red lines everything renders black)



PICTURE 5: (most frequent polygonal content. NOTE: DOES change when looking around/moving.)






PICTURE 7: (MOST common thing I see in game.)



PICTURE 8: (HBAO+ enabled)



PICTURE 9: (minimal graphics setting)



PICTURE 10: (objects annotations display occasionally)


Edited by h2stipandav

Share this post

Link to post
Share on other sites

8 replies to this bug / suggestion

Recommended Posts

  • 0

I tested my video card in another PC, and despite of heavy lag(!?), everything seemed to render normally.

win 7 ultimate (updated), 2x 2,67 Ghz, 80GB RAM

Ill try to get the original PC updated too, to see if that helps.

Edited by h2stipandav

Share this post

Link to post
Share on other sites
  • 0

Got it working!

One of the 144 Windows updates I installed after the first two KB3020369 and KB3161608 (those two will make windows update work properly, but didn't fix Ylands) has solved my rendering problem.
Though I have no idea which one did the magic. Maybe "Windows 7 Service Pack 1"
Also I activated Windows..

Game runs perfectly! :)

List of updates:


Edited by h2stipandav
  • Upvote 1

Share this post

Link to post
Share on other sites
  • 0

Could you send us your output_log file, please? (this should be in the directory \Program Files\Ylands\Game\Ylands_Data) 

Glad to know you managed to get the game working, btw! 

Share this post

Link to post
Share on other sites
  • 0

1) After minimizing game to taskbar and returning to game, no more sounds or music are played.
2) When loading your savegame with torch held in hand, there are two flames.[PIC 1,2] After switching away to another item and back to torch, flame renders normal. [PIC 3]
Sorry, if I'm reposting.




Edited by h2stipandav

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this