Jump to content
Sign in to follow this  
RedEagle_P1.

Can't replenish lost starfish on pick. What am I doing wrong?

Recommended Posts

Posted (edited)
On 6/6/2019 at 5:48 PM, RedEagle_P1. said:

1e04d0d821f29ad63106e5b914722f06.png
 

At spawn, it is getting the coords of item that is inside on inventory already (so it has no really coords). 

So, bellow the ON pick at event trigger, store the position of target entity at a variable. Then inside Spawn block, use the variable. 

ON PICK

Local Variable variable_item_coord Get entity position(target position) 

Spawn entity.... Etc etc

 

That should work. I had I working 

Edited by jchob

Share this post


Link to post
Share on other sites

Hi, or in 0.13 you can use just "On pick start" -> Target entity will be the one picked.

Share this post


Link to post
Share on other sites
On 6/11/2019 at 10:56 AM, Houp said:

Hi, or in 0.13 you can use just "On pick start" -> Target entity will be the one picked.

I'll wait for update then 😁

Any place where I can see the editor scripting new stuff? Like the wiki page with 0.11 and 0.12 stuff. Thanks

Share this post


Link to post
Share on other sites

Thanks @Houp I already saw it. When I checked that page it wasn't updated yet. Will someone add example for the object movement tile? Or is it "easy" to understand?

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×